Failed Scipy Install

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Failed Scipy Install

bfrenay
Dear All,

I am trying to install Scipy on a CentOS machine.  After installing Python 2.7.1 and Numpy 1.5.1, I tried to install Scipy 0.8.0 and got this message

creating build/temp.linux-x86_64-2.7/scipy/sparse/sparsetools
compile options: '-I/linux/frenay/centos_lib/lib/numpy-1.5.1/lib/python2.7/site-packages/numpy/core/include -I/linux/frenay/centos_lib/lib/Python-2.7.1/include/python2.7 -c'
g++: scipy/sparse/sparsetools/csr_wrap.cxx
scipy/sparse/sparsetools/csr_wrap.cxx: In function ‘int require_size(PyArrayObject*, npy_intp*, int)’:
scipy/sparse/sparsetools/csr_wrap.cxx:2910: error: expected ‘)’ before ‘PRIdPTR’
scipy/sparse/sparsetools/csr_wrap.cxx:2910: warning: spurious trailing ‘%’ in format
scipy/sparse/sparsetools/csr_wrap.cxx:2910: warning: too many arguments for format
scipy/sparse/sparsetools/csr_wrap.cxx:2917: error: expected ‘)’ before ‘PRIdPTR’
scipy/sparse/sparsetools/csr_wrap.cxx:2917: warning: spurious trailing ‘%’ in format
scipy/sparse/sparsetools/csr_wrap.cxx:2917: warning: too many arguments for format
scipy/sparse/sparsetools/csr_wrap.cxx: In function ‘int require_size(PyArrayObject*, npy_intp*, int)’:
scipy/sparse/sparsetools/csr_wrap.cxx:2910: error: expected ‘)’ before ‘PRIdPTR’
scipy/sparse/sparsetools/csr_wrap.cxx:2910: warning: spurious trailing ‘%’ in format
scipy/sparse/sparsetools/csr_wrap.cxx:2910: warning: too many arguments for format
scipy/sparse/sparsetools/csr_wrap.cxx:2917: error: expected ‘)’ before ‘PRIdPTR’
scipy/sparse/sparsetools/csr_wrap.cxx:2917: warning: spurious trailing ‘%’ in format
scipy/sparse/sparsetools/csr_wrap.cxx:2917: warning: too many arguments for format
error: Command "g++ -pthread -fno-strict-aliasing -g -O2 -DNDEBUG -g -fwrapv -O3 -Wall -fPIC -I/linux/frenay/centos_lib/lib/numpy-1.5.1/lib/python2.7/site-packages/numpy/core/include -I/linux/frenay/centos_lib/lib/Python-2.7.1/include/python2.7 -c scipy/sparse/sparsetools/csr_wrap.cxx -o build/temp.linux-x86_64-2.7/scipy/sparse/sparsetools/csr_wrap.o" failed with exit status 1

Any idea of the problem ?

Thank you for your help !
Reply | Threaded
Open this post in threaded view
|

Re: Failed Scipy Install

Pauli Virtanen-3
10.09.2013 16:57, bfrenay kirjoitti:
> I am trying to install Scipy on a CentOS machine.  After installing Python
> 2.7.1 and Numpy 1.5.1, I tried to install Scipy 0.8.0 and got this message

You are trying to install an obsolete version of Scipy. Try a more
recent release (latest is 0.12.0).

If you really want to use the old version, apply changeset
1c3f75f8e1e0ed3900d0b5f72527172882c98b2e

--
Pauli Virtanen

_______________________________________________
SciPy-User mailing list
[hidden email]
http://mail.scipy.org/mailman/listinfo/scipy-user