Lib/linsolve/umfpack/umfpack.i:192: Error: Unable to find 'umfpack.h'

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Lib/linsolve/umfpack/umfpack.i:192: Error: Unable to find 'umfpack.h'

dikshie-2
Hi,
i have strange situation here.
when i installed numpy and scipy on new PC, i dont have any problems.
BUT when i try installed, deinstall, and re-install i always get:
---------------------------------------------------------------------------
swig: Lib/linsolve/umfpack/umfpack.i
swig -python -o
build/src.freebsd-7.0-STABLE-amd64-2.5/Lib/linsolve/umfpack/_umfpack_wrap.c
-outdir build/src.freebsd-7.0-STABLE-amd64-2.5/Lib/linsolve/umfpack
Lib/linsolve/umfpack/umfpack.i
Lib/linsolve/umfpack/umfpack.i:192: Error: Unable to find 'umfpack.h'
Lib/linsolve/umfpack/umfpack.i:193: Error: Unable to find 'umfpack_solve.h'
Lib/linsolve/umfpack/umfpack.i:194: Error: Unable to find 'umfpack_defaults.h'
Lib/linsolve/umfpack/umfpack.i:195: Error: Unable to find
'umfpack_triplet_to_col.h'
Lib/linsolve/umfpack/umfpack.i:196: Error: Unable to find
'umfpack_col_to_triplet.h'
------------------------------------------------------------------------------
same error message when i tried to upgrade scipy.
try to ldconfig -m /usr/local/include does not help.

any clue?

with best regards,

-dikshie-
_______________________________________________
SciPy-user mailing list
[hidden email]
http://projects.scipy.org/mailman/listinfo/scipy-user
Reply | Threaded
Open this post in threaded view
|

Re: Lib/linsolve/umfpack/umfpack.i:192: Error: Unable to find 'umfpack.h'

David Huard
Hi,

Try editing the site.cfg file in the scipy directory with the following:

[umfpack]
library_dirs=/usr/lib64
include_dirs=/usr/include/suitesparse

This is on FC8. You might have to change the include_dirs for your distro ($ locate umfpack.h)

David


2008/4/18, dikshie <[hidden email]>:
Hi,
i have strange situation here.
when i installed numpy and scipy on new PC, i dont have any problems.
BUT when i try installed, deinstall, and re-install i always get:
---------------------------------------------------------------------------
swig: Lib/linsolve/umfpack/umfpack.i
swig -python -o
build/src.freebsd-7.0-STABLE-amd64-2.5/Lib/linsolve/umfpack/_umfpack_wrap.c
-outdir build/src.freebsd-7.0-STABLE-amd64-2.5/Lib/linsolve/umfpack
Lib/linsolve/umfpack/umfpack.i
Lib/linsolve/umfpack/umfpack.i:192: Error: Unable to find 'umfpack.h'
Lib/linsolve/umfpack/umfpack.i:193: Error: Unable to find 'umfpack_solve.h'
Lib/linsolve/umfpack/umfpack.i:194: Error: Unable to find 'umfpack_defaults.h'
Lib/linsolve/umfpack/umfpack.i:195: Error: Unable to find
'umfpack_triplet_to_col.h'
Lib/linsolve/umfpack/umfpack.i:196: Error: Unable to find
'umfpack_col_to_triplet.h'
------------------------------------------------------------------------------
same error message when i tried to upgrade scipy.
try to ldconfig -m /usr/local/include does not help.

any clue?

with best regards,


-dikshie-
_______________________________________________
SciPy-user mailing list
[hidden email]
http://projects.scipy.org/mailman/listinfo/scipy-user


_______________________________________________
SciPy-user mailing list
[hidden email]
http://projects.scipy.org/mailman/listinfo/scipy-user
Reply | Threaded
Open this post in threaded view
|

Re: Lib/linsolve/umfpack/umfpack.i:192: Error: Unable to find 'umfpack.h'

dikshie-2
On Fri, Apr 18, 2008 at 10:41 PM, David Huard <[hidden email]> wrote:

> Hi,
>
> Try editing the site.cfg file in the scipy directory with the following:
>
> [umfpack]
> library_dirs=/usr/lib64
> include_dirs=/usr/include/suitesparse
>
> This is on FC8. You might have to change the include_dirs for your distro ($
> locate umfpack.h)

solved.
1.I removed suitesparse and octave.
2.install scipy
3.re-install suitesparse and octave.



-dikshie-
_______________________________________________
SciPy-user mailing list
[hidden email]
http://projects.scipy.org/mailman/listinfo/scipy-user