[SciPy-User] ANN: pybroom 0.2 released

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[SciPy-User] ANN: pybroom 0.2 released

Antonino Ingargiola
Hi,

version 0.2 of pybroom has been released. See below for the details.

What is pybroom?
==============

Pybroom is a small python 3+ library for converting collections of fit results (curve fitting or other optimizations) to Pandas DataFrame in tidy format (or long-form) (Wickham 2014). Once fit results are in tidy DataFrames, it is possible to leverage common patterns for tidy data analysis. Furthermore powerful visual explorations using multi-facet plots becomes easy thanks to libraries like seaborn natively supporting tidy DataFrames.

Homepage: http://pybroom.readthedocs.io/


Release Notes
============

- Improved support for scipy.optimize fit result.
- In addition to list of fit results, pybroom now supports:
      - dict of fit results,
      - dict of lists of fit results
      - any other nested combination of dict and list.
- When input contains a dict, pybroom adds “key” column of type pandas.Categorical. 
- When input contains a list, pybroom adds a “key” column (i.e. list index) of type int64.
- Updated and expanded documentation and notebooks.


Installation
========

You can install pybroom from PyPI using the following command:

    pip install pybroom

or from conda-forge using:

    conda install -c conda-forge pybroom

Dependencies are python 3.4+, pandas and lmfit (0.9.5+, which in turn requires scipy).
However, matplotlib and seaborn are strongly recommended (and necessary
to run the example notebooks).

_______________________________________________
SciPy-User mailing list
[hidden email]
https://mail.scipy.org/mailman/listinfo/scipy-user
Loading...