[SciPy-User] Re : Installing scipy on MacOS X

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

[SciPy-User] Re : Installing scipy on MacOS X

Oleksandr Huziy
Hi
Sorry for the trivial questions:

Have you activated your virtualenv before using pip?
What is the output of pip list?
Activate tour virtualenv and to install using pip install scipy.

Cheers



15 juin 2015, à 17:13, "Slater Joseph C , PhD, PE" <[hidden email]> a écrit :


> On Jun 15, 2015, at 4:07 PM, Ralf Gommers <[hidden email]> wrote:
> <snip>
>> </snip>
>
> This is trying to use ATLAS, do you have that installed? I'd expect all those source builds to use Accelerate.

I did not install it myself. My understanding from reading the docs is that it would build without is (using Accelerate). Do I have to do something to force it to recognize/use Accelerate? Likely I do, but shouldn't have to from what I understand.

>
> Can you:
> - give us the full build command you used

python setup.py install

> - put the complete build log in a gist and link to it

First time I've seen gist. Cool!

https://gist.github.com/josephcslater/0930741203fd02dbcc0f#file-scipy-install-log-txt


> - check that ``python -c "import numpy; numpy.test('full')`` passes

Some failures. Log in the https://gist.github.com/josephcslater/0930741203fd02dbcc0f#file-gistfile1-txt 

numpy was installed in the virtualenv using pip.
sudo -H  pip3 install numpy matplotlib
no errors resulted from that.

>
> I've been using Homebrew and gfortran 4.9.1 for a year or so without issues.

I'm now at 5.10 . I've been interchanging variables, blindly (due to lack of knowledge).

Thanks,
Joe


>
> Ralf
> <snip>

_______________________________________________
SciPy-User mailing list
[hidden email]
http://mail.scipy.org/mailman/listinfo/scipy-user
_______________________________________________
SciPy-User mailing list
[hidden email]
http://mail.scipy.org/mailman/listinfo/scipy-user
Reply | Threaded
Open this post in threaded view
|

Re: Re : Installing scipy on MacOS X

Slater Joseph C , PhD, PE

> On Jun 15, 2015, at 8:34 PM, Oleksandr Huziy <[hidden email]> wrote:
>
> Hi
> Sorry for the trivial questions:

Not at all. A presumption of incompetence on my part may not be far off. I've just started this "journey".
>
> Have you activated your virtualenv before using pip?

Yes.

> What is the output of pip list?

(scipy-dev)[jslater@Norma scipy-dev]$ pip list
Cython (0.22)
delocate (0.6.2)
matplotlib (1.4.3)
nose (1.3.7)
numpy (1.9.2)
pip (7.0.3)
pyparsing (2.0.3)
python-dateutil (2.4.2)
pytz (2015.4)
setuptools (17.0)
sh (1.11)
six (1.9.0)
wheel (0.24.0)

> Activate tour virtualenv and to install using pip install scipy.

That, however, will undermine my intent, which is to be working with the developer version. I'm not the best in Python... but I'm sufficiently capable, and more so in my field, to extend it. There is another gentleman working on extending signal/spectral overlapping what I'm doing. It makes more sense for me to be working in concert rather than as another disjointed signal processing effort.

Nevertheless, I've installed it. It was successful. However, I really need to be using my fork, if anyone can help me figure out what I've done wrong... probably something harebrained.

Joe





>
> Cheers
>
>
>
> 15 juin 2015, à 17:13, "Slater Joseph C , PhD, PE" <[hidden email]> a écrit :
>
>
>> On Jun 15, 2015, at 4:07 PM, Ralf Gommers <[hidden email]> wrote:
>> <snip>
>>> </snip>
>>
>> This is trying to use ATLAS, do you have that installed? I'd expect all those source builds to use Accelerate.
>
> I did not install it myself. My understanding from reading the docs is that it would build without is (using Accelerate). Do I have to do something to force it to recognize/use Accelerate? Likely I do, but shouldn't have to from what I understand.
>
>>
>> Can you:
>> - give us the full build command you used
>
> python setup.py install
>
>> - put the complete build log in a gist and link to it
>
> First time I've seen gist. Cool!
>
> https://gist.github.com/josephcslater/0930741203fd02dbcc0f#file-scipy-install-log-txt
>
>
>> - check that ``python -c "import numpy; numpy.test('full')`` passes
>
> Some failures. Log in the https://gist.github.com/josephcslater/0930741203fd02dbcc0f#file-gistfile1-txt 
>
> numpy was installed in the virtualenv using pip.
> sudo -H  pip3 install numpy matplotlib
> no errors resulted from that.
>
>>
>> I've been using Homebrew and gfortran 4.9.1 for a year or so without issues.
>
> I'm now at 5.10 . I've been interchanging variables, blindly (due to lack of knowledge).
>
> Thanks,
> Joe
>
>
>>
>> Ralf
>> <snip>
>
> _______________________________________________
> SciPy-User mailing list
> [hidden email]
> http://mail.scipy.org/mailman/listinfo/scipy-user
> _______________________________________________
> SciPy-User mailing list
> [hidden email]
> http://mail.scipy.org/mailman/listinfo/scipy-user

_______________________________________________
SciPy-User mailing list
[hidden email]
http://mail.scipy.org/mailman/listinfo/scipy-user