[SciPy-User] Ubuntu 12.04 Scipy and Numpy Versions Outdated

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

[SciPy-User] Ubuntu 12.04 Scipy and Numpy Versions Outdated

Robinson, Calvin R. (GRC-VM00)

My current scipy and numpy versions are 1.6.1 and 0.9. I was going to update them using Ubuntu’s package manager but it turns out for 12.04, those are the latest versions. Are there other repositories I can use to update these packages?

 

Thanks

 

Calvin


_______________________________________________
SciPy-User mailing list
[hidden email]
http://mail.scipy.org/mailman/listinfo/scipy-user
Reply | Threaded
Open this post in threaded view
|

Re: Ubuntu 12.04 Scipy and Numpy Versions Outdated

Andreas-119
> My current scipy and numpy versions are 1.6.1 and 0.9. I was going to
> update them using Ubuntu’s package manager but it turns out for 12.04,
> those are the latest versions. Are there other repositories I can use to
> update these packages?

Hi Calvin,

I created a PPA for this purpose. See my mail at
http://mail.scipy.org/pipermail/scipy-user/2013-February/034165.html. So
far, I only put scipy 0.11 up there. Any help in packaging is welcome ;)

Cheers, Andreas.

_______________________________________________
SciPy-User mailing list
[hidden email]
http://mail.scipy.org/mailman/listinfo/scipy-user
Reply | Threaded
Open this post in threaded view
|

Re: Ubuntu 12.04 Scipy and Numpy Versions Outdated

Thomas Kluyver-2
On 26 February 2013 15:01, Andreas Hilboll <[hidden email]> wrote:
I created a PPA for this purpose. See my mail at
http://mail.scipy.org/pipermail/scipy-user/2013-February/034165.html. So
far, I only put scipy 0.11 up there. Any help in packaging is welcome ;)

If you're lucky, a package can be backported with a single command:

backportpackage -u ppa:pylab/stable -s raring -d precise python-numpy

(the options being u for upload, s for source and d for destination).

Of course, there might be more to do than that - e.g. in this case, I think you'll need to backport python-tz first, because it has a build dependency on python3-tz, which isn't in precise.

Thomas

_______________________________________________
SciPy-User mailing list
[hidden email]
http://mail.scipy.org/mailman/listinfo/scipy-user