[SciPy-User] update scipy to v.0.15 from spyder on windows seven 64 bits

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

[SciPy-User] update scipy to v.0.15 from spyder on windows seven 64 bits

servant mathieu
Dear community,

I've the latest python (x,y) distribution (2.7.9.0) which incorporates spyder 2.3.2-14 and scipy 0.14.0-7. Unfortunately, I need scipy 0.15 to use the new scipy.optimize.differential_evolution() function. How should I proceed to (easily) update scipy from my spyder? 

Best,
Mathieu

_______________________________________________
SciPy-User mailing list
[hidden email]
http://mail.scipy.org/mailman/listinfo/scipy-user
Reply | Threaded
Open this post in threaded view
|

Re: update scipy to v.0.15 from spyder on windows seven 64 bits

ralfgommers


On Fri, Apr 24, 2015 at 10:45 AM, Servant Mathieu <[hidden email]> wrote:
Dear community,

I've the latest python (x,y) distribution (2.7.9.0) which incorporates spyder 2.3.2-14 and scipy 0.14.0-7. Unfortunately, I need scipy 0.15 to use the new scipy.optimize.differential_evolution() function. How should I proceed to (easily) update scipy from my spyder?

I don't know how Python(x,y) builds its packages. If you need to upgrade Scipy it's probably best to ask for advice on the Python(x,y) mailing list.

Note though that differential_evolution is pure Python code, so the path of least resistance may be to just take this file: https://github.com/scipy/scipy/blob/master/scipy/optimize/_differentialevolution.py and add an import to optimize/__init__.py to make the function available in your current install.

Ralf



_______________________________________________
SciPy-User mailing list
[hidden email]
http://mail.scipy.org/mailman/listinfo/scipy-user