problems wtih _sparsetools and SfePy

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

problems wtih _sparsetools and SfePy

Ryan Krauss-2
I am trying to get started with SfePy and am having some troubles
running their tests.  I have everything working correctly on one
computer, but not on my laptop.  Both computers are running Ubuntu
7.10.  My current problem is this:

/usr/lib/python2.5/site-packages/scipy/sparse/sparsetools.py in
csr_matvec(*args)
    590         npy_clongdouble_wrapper Xx, npy_clongdouble_wrapper Yx)
    591     """
--> 592   return _sparsetools.csr_matvec(*args)
    593
    594 def csc_matvec(*args):

<type 'exceptions.AttributeError'>: 'module' object has no attribute
'csr_matvec'

It seems that  _sparetools.so is different on the two machines and I
don't know why.  Both are running
In [1]: scipy.version.version
Out[1]: '0.7.0.dev3851'

from svn a while back.  I just tried rebuilding and re-installing from
source and noticed that _sparesetools was not affected.  Where does
_sparsetools come from and how would I change how it gets created?  On
the desktop without problems, the file is 7.8 megs, on the laptop with
problems it is only 1.9 megs.  So, it seems I have some configuration
differences somewhere, but I don't know where.

Thanks,

Ryan
_______________________________________________
SciPy-user mailing list
[hidden email]
http://projects.scipy.org/mailman/listinfo/scipy-user
Reply | Threaded
Open this post in threaded view
|

Re: problems wtih _sparsetools and SfePy

Nathan Bell-4
On Thu, May 15, 2008 at 2:57 PM, Ryan Krauss <[hidden email]> wrote:
>
> from svn a while back.  I just tried rebuilding and re-installing from
> source and noticed that _sparesetools was not affected.  Where does
> _sparsetools come from and how would I change how it gets created?  On
> the desktop without problems, the file is 7.8 megs, on the laptop with
> problems it is only 1.9 megs.  So, it seems I have some configuration
> differences somewhere, but I don't know where.
>

Ryan, you shouldn't have a _sparsetools.so anymore.  There should be a
sparsetools/ directory with several shared objects inside (e.g.
_csr.so).

Try removing your scipy/build directory and site-packages/scipy
directory and installing again.

--
Nathan Bell [hidden email]
http://graphics.cs.uiuc.edu/~wnbell/
_______________________________________________
SciPy-user mailing list
[hidden email]
http://projects.scipy.org/mailman/listinfo/scipy-user
Reply | Threaded
Open this post in threaded view
|

Re: problems wtih _sparsetools and SfePy

Ryan Krauss-2
Thanks Nathan.  I seem to be up and running.

On Thu, May 15, 2008 at 3:09 PM, Nathan Bell <[hidden email]> wrote:

> On Thu, May 15, 2008 at 2:57 PM, Ryan Krauss <[hidden email]> wrote:
>>
>> from svn a while back.  I just tried rebuilding and re-installing from
>> source and noticed that _sparesetools was not affected.  Where does
>> _sparsetools come from and how would I change how it gets created?  On
>> the desktop without problems, the file is 7.8 megs, on the laptop with
>> problems it is only 1.9 megs.  So, it seems I have some configuration
>> differences somewhere, but I don't know where.
>>
>
> Ryan, you shouldn't have a _sparsetools.so anymore.  There should be a
> sparsetools/ directory with several shared objects inside (e.g.
> _csr.so).
>
> Try removing your scipy/build directory and site-packages/scipy
> directory and installing again.
>
> --
> Nathan Bell [hidden email]
> http://graphics.cs.uiuc.edu/~wnbell/
> _______________________________________________
> SciPy-user mailing list
> [hidden email]
> http://projects.scipy.org/mailman/listinfo/scipy-user
>
_______________________________________________
SciPy-user mailing list
[hidden email]
http://projects.scipy.org/mailman/listinfo/scipy-user