scipy installation error on Mac OS X (10.6.8) (with pip)

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

scipy installation error on Mac OS X (10.6.8) (with pip)

Peng Yu
Hi,

I get the following error. When I try to instal scipy (pip install
scipy). Does anybody know how to fix the problem?

....

error: Command "/opt/local/bin/g95 -shared -shared
build/temp.macosx-10.6-intel-2.7/build/src.macosx-10.6-intel-2.7/scipy/fftpack/_fftpackmodule.o
build/temp.macosx-10.6-intel-2.7/scipy/fftpack/src/zfft.o
build/temp.macosx-10.6-intel-2.7/scipy/fftpack/src/drfft.o
build/temp.macosx-10.6-intel-2.7/scipy/fftpack/src/zrfft.o
build/temp.macosx-10.6-intel-2.7/scipy/fftpack/src/zfftnd.o
build/temp.macosx-10.6-intel-2.7/build/src.macosx-10.6-intel-2.7/scipy/fftpack/src/dct.o
build/temp.macosx-10.6-intel-2.7/build/src.macosx-10.6-intel-2.7/scipy/fftpack/src/dst.o
build/temp.macosx-10.6-intel-2.7/build/src.macosx-10.6-intel-2.7/fortranobject.o
-Lbuild/temp.macosx-10.6-intel-2.7 -ldfftpack -lfftpack -o
build/lib.macosx-10.6-intel-2.7/scipy/fftpack/_fftpack.so" failed with
exit status 1


--
Regards,
Peng
_______________________________________________
SciPy-User mailing list
[hidden email]
http://mail.scipy.org/mailman/listinfo/scipy-user
Reply | Threaded
Open this post in threaded view
|

Re: scipy installation error on Mac OS X (10.6.8) (with pip)

David Cournapeau


On Wed, Apr 11, 2012 at 10:39 PM, Peng Yu <[hidden email]> wrote:
Hi,

I get the following error. When I try to instal scipy (pip install
scipy). Does anybody know how to fix the problem?

Don't use g95 as a fortran compiler, it is known to be severly broken, especially on mac os x. Use gfortran itself.

David

_______________________________________________
SciPy-User mailing list
[hidden email]
http://mail.scipy.org/mailman/listinfo/scipy-user