scipy.test() failure at 'generic filter 1'

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

scipy.test() failure at 'generic filter 1'

Benedikt Koenig
Dear all,

scipy 0.6.0 built went without problems and scipy.test() fails with a
seg fault. Numpy 1.0.4 installed and tested without problems. I am
running centos4 with Python 2.3.4 on an i586.

The last part of the output of
python -c 'import numpy; import scipy; scipy.test(1, verbosity=2)'
reads to:
<quote>
gaussian filter 1 ... ok
gaussian filter 2 ... ok
gaussian filter 3 ... ok
gaussian filter 4 ... ok
gaussian filter 5 ... ok
gaussian filter 6 ... ok
gaussian gradient magnitude filter 1 ... ok
gaussian gradient magnitude filter 2 ... ok
gaussian laplace filter 1 ... ok
gaussian laplace filter 2 ... ok
generation of a binary structure 1 ... ok
generation of a binary structure 2 ... ok
generation of a binary structure 3 ... ok
generation of a binary structure 4 ... ok
generic filter 1Speicherschutzverletzung
</quote>
('Speicherschutzverletzung' means seg fault)

The same problem was reported in
http://thread.gmane.org/gmane.comp.python.scientific.user/13774
and Stefan van der Walt answered that this bug has been fixed.

Can anyone tell me where to find this bug fix, or how to otherwise get
rid of this error?



Actually, I am not sure whether I really care about the 'generic filter'
stuff but there seems to be some other problem with 0.6.0. A script that
ran fine using scipy 0.5.2 gets stuck under my new 0.6.0 installation.
No error is given but the line
>>> data_cfd = fromfile(cfdfile, dtype=float, sep=' ').reshape(-1,19),
which took a few seconds to process, is now using 100% cpu for several
minutes before I kill it. No error or hint whatsoever what is going.
Any idea what's happening there?

Thanks,
bene


_______________________________________________
SciPy-user mailing list
[hidden email]
http://projects.scipy.org/mailman/listinfo/scipy-user
Reply | Threaded
Open this post in threaded view
|

Re: scipy.test() failure at 'generic filter 1'

Stéfan van der Walt
Hi Benedikt

2008/5/6 Benedikt Koenig <[hidden email]>:
>  scipy 0.6.0 built went without problems and scipy.test() fails with a
>  seg fault. Numpy 1.0.4 installed and tested without problems. I am
>  running centos4 with Python 2.3.4 on an i586.

This problem had been fixed in SVN a while ago already.

Regards
Stéfan
_______________________________________________
SciPy-user mailing list
[hidden email]
http://projects.scipy.org/mailman/listinfo/scipy-user